
Photography Post-Processing Workshop 2
Photoshop Composites

Level: Intermediate/Advanced

This workshop will include working with Layers, Masks, Channels, Brushes, Adjustment 
Layers, Filters & other intermediate to advanced tools. It assumes you have some basic 
experience with Photoshop and understanding of the core principles of photography.  It is 
also advantageous to have completed Workshop 1: Photoshop Beyond the Basics.

I. Creating cutouts
There are several ways of cutting out an object from one photo and bringing it into 
another. I have detailed several ways of doing it below, and the best one to use will 
depend on the image & background; you may also end up using multiple techniques to 
make a single cutout. Regardless of which method you use, make sure you blend the 
cutout to make it fit into the destination image.

A. Selection Cutout Methods
The best selection method will depend on the object and background of the image 
you are cutting out from:

1. Magic Wand: Solid coloured background, simple-shaped object
a) Use the Magic Wand tool to select the background. Make sure Anti-alias is 

ticked, and set Tolerance according to the difference between the background 
colour & the object (low for similar colours, high for very different).
TIP: You might want to switch to the Red, Green or Blue Channel while 
selecting. Choose whichever channel shows the greatest contrast between 
your object & image. Make sure you switch back to RGB channel after making 
your selection.

b) Select the Inverse (CMD+SHIFT+I)
c) Zoom to 100% and make sure everything is selected. If not, use the Lasso tool 

and hold down the SHIFT key to add to the selection, or the ALT key to 
subtract from the selection.
TIP: You may want to use Quick Mask mode for this step. Simply click the 
Quick Mask icon at the bottom of the main palette to switch back & forth 
between selection/mask. Paint into the mask with black or erase with white.

d) Contract the selection by 1 or 2 pixels (2 if the image is very hi-res & the object 
is large) by going to Select > Modify > Contract.

e) Add a small feather or 0.5 or 1 pixels (depending on the image) by going to 
Select > Feather

f) Drag your selection into the destination file to add it as a new layer.
g) If you see a halo, you might want to use Layer > Matting > Defringe... to 

remove it, or repeat step C and/or D to remove it.
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TIP: An alternative to this method is the one used to replace dull skies (See 
Step II.A below).

2. Magnetic Lasso: Background is very different colour/tone from simple-shaped 
object (but not solid coloured)
a) Use the Magnetic Lasso to draw carefully around the object. Make sure Anti-

alias is ticked, and set the Width and Edge Contrast according to the the 
image.
TIP: You might want to switch to the Red, Green or Blue Channel while 
selecting. Choose whichever channel shows the greatest contrast between 
your object & image. Make sure you switch back to RGB channel after making 
your selection.

b) Zoom to 100% and make sure everything is selected. If not, use the Lasso tool 
and hold down the SHIFT key to add to the selection, or the ALT key to 
subtract from the selection.
TIP: You may want to use Quick Mask mode for this step. Simply click the 
Quick Mask icon at the bottom of the main palette to switch back & forth 
between selection/mask. Paint into the mask with black or erase with white.

c) Contract the selection by 1 or 2 pixels (2 if the image is very hi-res & the object 
is large) by going to Select > Modify > Contract.

d) Add a small feather or 0.5 or 1 pixels (depending on the image) by going to 
Select > Feather

e) Drag your selection into the destination file to add it as a new layer.
f) If you see a halo, you might want to use Layer > Matting > Defringe... to 

remove it, or repeat step C and/or D to remove it.

3. Channel Selection & Mask: Object is irregular in shape and has ‘wispy’ bits (like 
hair). Background can be anything.
a) Click on the different Channels (Red, Green, or Blue) and find the one which 

shows the greatest contrast between the object & the background.
b) Duplicate the Channel by dragging it to the New Layer icon at the bottom of 

the palette, and name this new channel layer ‘Mask’.
c) Making sure you are working on the copied Mask channel, use the Lasso tool 

to draw loosely around  the edge of the object (making sure to include the 
wispy areas), including part of the background & part of the object in your loop.

d) With the selection still active, use Image > Adjustments > Levels to increase the 
contrast as much as possible without losing the detail of the wisps (drag black 
& white sliders inward).

e) Repeat Step D again all around the image. You may need to duplicate step D 
on some areas, to ideally end up with stark black/white contrast (white = 
object, black = background).

f) Now paint out the centre of the object with white, taking care not to paint too 
close to the edges. Change brush size several times if need be.

g) Select or paint out the entire background with black, so you just have pure 
black (masked) & pure white (unmasked).
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h) Now select the RGB channel, and enter Quick Mask mode to double-check 
you have masked out all the areas. You can make any adjustments while in 
Quick Mask mode by painting black or white into the Mask layer.

i) To gently soften the edges of the selection, you may want to apply a 0.5 to 1 
pixel Gaussian Blur to the mask while in Quick Mask mode. Notice that the blur 
only affects the Mask (not the image) when in Quick Mask mode.

j) Now load the selection (making sure you are on RGB Channel), and copy/paste 
into a new layer. I prefer this instead of deleting the background, so I can go 
back if I need to.

4. Channel Selection & Mask - ALTERNATIVE TECHNIQUE: Object is irregular in 
shape and has ‘wispy’ bits (like hair). Background can be anything.
a) Click on the different Channels (Red, Green, or Blue) and find the one which 

shows the greatest contrast between the object & the background.
b) Duplicate the Channel by dragging it to the New Layer icon at the bottom of 

the palette, and name this new channel layer ‘Mask’.
c) Making sure you are on the new Mask Channel, go to Image > Apply Image 

and choose Overlay as the blending mode. This will make the contrast even 
greater. You can also do this by going to Image > Adjustments > Curves and 
dragging the black and white inward. Make sure not to go too far.

d) Get a brush with a soft tip, and select black ink. Here’s the important bit: 
choose Overlay as the BRUSH BLEND MODE. Now you can paint over bits of 
hair and body that are dark but not quite black, and they will darken to black.

e) Now reverse the ink to white by clicking X, and do the same as you just did on 
light areas of background that are not quite white. Be careful around the hair.

f)
g) Now paint out the centre of the object with black, taking care not to paint too 

close to the edges. Change brush size several times if need be, or use other 
techniques like Magnetic Lasso and Fill until your object is entirely black.

h) Select or paint out the entire background with white, so you just have pure 
black (masked) & pure white (unmasked).

i) Load your selection by dragging the Mask layer onto the dotted circle, or CMD
+Click on the layer icon.

j) With the selection loaded, now click on the RGB channel, and then go click on 
the layer with the desired background.

k) To gently soften the edges of the selection, you may want to use Select > 
Refine Edges. Start with Contrast 40, Feather 0.5 and play with Radius to get a 
suitable edge.

l) Now make this selection into a mask by clicking on the Layer Mask icon.

B. Layer Mask Cutout Method
1. Draw a rough selection around the item you want to cut out, with the rectangle or 

Lasso tools. It is not important to be accurate at all.
2. Drag the selection into the destination file. It will appear on a new layer.
3. Click the Layer Mask icon to add a blank mask to the layer.
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4. Making sure the layer mask is selected (click on the icon), use black ink and a 
100% solid brush to paint onto the undesired areas of the layer to hide them.
TIP: REMEMBER THE MASK MANTRA: “Black conceals, white reveals”. You can 
also use the Magic Wand, Magnetic Lasso or other selection tools to select large 
areas, then click SHIFT+F5 to fill with black.

5. Resize, rotate and/or amend the perspective of the item as desired.

TIP: The Layer Mask method has one drawback: you will not be able to CMD+click 
on the layer to select the visible (unmasked) areas. This means you may not easily 
be able to create shadows or add selective adjustments to blend in the layer (Step 
C below). You can get around this by making sure the entire layer mask is filled with 
black, except for the unmasked object. Then, you can CMD+click on the layer 
mask icon to select the visible (unmasked) area. 

NOTE: Do not use the Layer Mask Cutout Method if you will need to blur your 
object a lot to make it blend in with the background.

C. Blending Cutouts
1. Once you have dragged your selection into your destination file, you can use 

Image > Adjustments > Match Color to make the colour tone match. Choose 
Source: the file you are working in, and Layer: background layer. Use the Fade 
slider to decrease the colour matching effect, and use the Luminance & Color 
Intensity sliders if necessary to make the match better.

2. Use the Transform tool to alter the scale or perspective to make the object more 
believable.
TIP: It’s always best to start with an object that closely matches the perspective of 
the destination image; you cannot realistically alter the perspective dramatically 
with the tools in Photoshop.

3. CMD+click on the layer to select the entire object, and add selective Adjustment 
Layer(s) to make the Levels/Curves/Brightness/Contrast match the image.

4. You may need to add a slight Gaussian Blur or add noise to make the object fit in 
with the background.

5. Fade the layer opacity slightly to reduce the ‘pasted on’ feeling, being careful not 
to go too far and let underlying layers show through. If you do get ‘bleed-through’, 
you can correct this by creating a new layer under your object, and using a small 
soft brush, painting with a solid colour that matches the background image.

6. Study the way the light is falling on the background image. Use the dodge & burn 
tools on areas of the object that do not match the background lighting.

7. Finally, add a drop shadow to complete the effect:
a) CMD+click to select the object, then create a new layer below it called 

Shadow.
b) With the selection still loaded, click on the Shadow layer and press SHIFT+F5 

to fill the layer with Black or a suitable shadow colour.
c) Using the move tool, position the shadow to match the lighting in the image.
d) Use Gaussian Blur to soften the edges of the shadow.
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e) Change the layer Blending Mode to Darken, and drop the opacity right down 
until it looks right.

f) Use the eraser tool and/or a soft brush to erase or add areas of shadow as 
needed.

TIP: Always choose images that have similar lighting when doing cutouts, or 
you may not be able to achieve a realistic composite, no matter how much 
blending you do.

II. Improving backgrounds
You can replace entire backgrounds, cover up areas that are unattractive or distracting, 
or blur the background to draw focus to foreground elements.

A. Replacing washed-out or dull skies
1. Duplicate the background layer (CTRL+J).
2. Create a solid coloured layer between the 2 versions of the background layer, and 

make the colour very different from the colour of the objects on the layer. This 
helps to show that you are erasing correctly.

3. Select the Background copy layer. 
4. In the toolbox, choose the Background Eraser tool (under Eraser), and use these 

settings:
a) Sampling: Continuous - if your background/sky has subtle tonal variations 

(usually the case)
b) Limits: Discontiguous - if you want to erase all areas of the background colour 

(usually the case)
c) Tolerance - level will depend on how big a difference in tone there is between 

the background & the objects, as well as if the background has subtle tonal 
variations. Try 20 - 50% as a starting point.

5. Make sure your Background Eraser is set to a very large hard brush. Click on the 
Background Copy layer’s sky to erase, making sure the center crosshairs are 
touching background colour only. The center crosshairs are used to sample the 
colour & decide what to erase, so it’s critical they are on the sky colour when 
clicking.

6. Click all around the sky to remove it. I tend to click repeatedly rather than dragging, 
because it’s easy to accidentally drag the cross-hairs onto non-background colour. 
If you do make a mistake, correct with CTRL+Z.

7. You can touch up any fine areas by erasing the layer with a small eraser, or delete 
large empty expanses by dragging a selection around it & hitting backspace.

8. Once the sky is all gone, open up the new sky document & drag the new sky onto 
your destination file. 
TIP: Holding down the shift key when you drag with the Move/Arrow tool will 
automatically center-align the new sky.

9. Position the new sky under Background Copy layer, and tweak the levels, curves 
or colour as necessary by adding an Adjustment Layer.

M I K O    C O F F E Y    |    P H O T O G R A P H E R
 
 
 
 
         5

www.mikocoffey.com/photography  •  mail@mikocoffey.com

http://www.mikocoffey.com
http://www.mikocoffey.com
mailto:mail@mikocoffey.com
mailto:mail@mikocoffey.com


B. Replacing undesired areas of background
1. Select foreground elements using one of the cutout selection techniques above.
2. Duplicate foreground onto a new layer.
3. Create an empty layer between the new foreground layer and the background 

layer.
4. In this ‘sandwiched’ layer, paste new elements or use the Clone Stamp tool to 

paint over & hide undesired areas of the background. 
TIP: Hide the new foreground layer and tick Sample All Layers box when using the 
Clone Stamp tool to paint into the sandwiched layer.

C. Faking depth of field to reduce emphasis on the background
1. Select foreground elements using one of the cutout selection techniques above.
2. Duplicate foreground onto a new layer.
3. Make a copy of the background layer.
4. With this copy selected, go to Filter > Lens Blur and drag the sliders to create the 

effect of a shallow depth of field to blur out the background.
TIP: To create a more realistic depth of field effect, use a gradient Layer Mask 
before adding the Lens Blur. Mask out areas at the front entirely & use a Black-to-
White gradient. Load the mask as a selection, and then perform the Lens Blur. This 
will create a gradual blur moving toward the distance.

5. With this same layer selected, use Filter > Liquify to remove any ‘halo’ effect 
created by the blurring. Push the pixels inward using the Forward Warp tool so 
they will be hidden by the top foreground layer elements.

6. Optional: You may also want to darken or lighten this background layer using a 
Levels Adjustment Layer to make the foreground elements stand out even more.

III. Adding overall textures or grungy, aged effects
You can create textures that simulate handmade paper, delicate rice paper, or make your 
photo look like it has been around for years & taken a real beating.

A. Using an existing texture image
These textures create a distressed/grungy/aged look. First, you will need a texture 
image. This could be a photo of old paper, rusty metal, peeling paint, or other 
‘distressed’ looking object. 

You can download free texture files from the internet; good places to look:
http://browse.deviantart.com/?qh=&section=&q=textures
http://www.parablevisions.com/2009design/menu.html 
http://www.sxc.hu/

I have also included a few of my favourites as downloads on my website.

1. Open up a texture image file.
2. Drag the textured image into your destination file to create a new layer.
3. Change the layer Blending Mode to Multiply.
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4. If you don’t like the colour, CMD+SHIFT+U to Desaturate the layer, or CMD+I to 
invert the colours.

5. You can erase bits with a soft, semi-transparent eraser, or paint white, to remove 
or soften the texture effect on certain areas of the image.

6. Reduce the layer opacity if the effect is too strong.

B. Create your own texture using Renders or Fills
These textures are more uniform and tend to look more like different types of paper.
1. Open up the photo you want to apply texture & create a new layer.
2. Fill the layer with 50% gray (SHIFT+F5 to bring up the Fill dialog box).
3. Now you can create your texture by using either of these techniques:

a) Filter > Render. Choose Clouds, Difference Clouds or Fibers to create different 
effects.

b) Get the Paint Bucket tool, and choose Pattern (instead of Foreground) to paint 
with. Choose any of the preset patterns that you like, then click to fill the layer 
with that pattern.

4. Paint around using different brushes with black, white or grey if you want to make 
the texture less uniform.

5. Change the layer Blending Mode to Multiply.
6. You can erase bits with a soft, semi-transparent eraser, or paint white, to remove 

or soften the texture effect on certain areas of the image.
7. Reduce the layer opacity if the effect is too strong.

IV. Using Brushes to create decorations or textured effects
Photoshop Brushes are a wonderful and really easy way to get creative. Once you use 
custom brushes, you will become addicted! 

Some good resources where you can download free custom brushes:
http://www.brusheezy.com/
http://www.photoshopbrushes.com/brushes.htm
http://browse.deviantart.com/resources/applications/psbrushes/?order=9
http://brushes.500ml.org/list2.php

A. Add decorative effects or textures on top of the image
1. Create a new blank layer.
2. Select your desired brush and ink colour, and use the brackets [ and ] to increase 

or decrease the brush to the size you want.
3. Click once to paint the desired decoration/texture in the place you want it. Rotate, 

transform,  or fade the opacity to get the desired effect.
TIP: If you increase the brush size too far beyond the default size, you will get a soft 
or pixellated edge, so it’s best to avoid this.

B. Add grungy/distressed effects that fade or distress parts of the actual image
1. Create a duplicate of the background layer.
2. Create a new layer under this, and fill with white or cream.
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3. Select the background copy, and add a blank layer mask to the layer by clicking 
the Layer Mask icon at the bottom of the layers palette.

4. Make sure you have black ink, choose the brush you want to use, and use the 
brackets [ ] to increase or decrease to the size you want.

5. Making sure the layer mask is highlighted, click once on the image to paint the 
brush effect into the mask. This will fade the image in that area, letting the white/
cream show through.
TIP: Drop the opacity of the brush before painting, or paint over the mask with a 
semi-transparent white to decrease the effect.

You can also create your own brushes as a way to save time (for example, creating a 
brush with your signature). Here’s a quick tutorial on creating brushes: 
http://www.wikihow.com/Create-Brushes-Using-Photoshop-CS

V. Adding borders
There are many different ways of creating an arty border; here’s a few:

A. ‘Painted Edges’ Layer method
This creates an irregular border around the image.
1. Create a new layer on top of all the other layers.
2. Use a variety of non-standard brushes to paint around the edges of this layer using 

black or white. Some suggested brushes to try: Spatter, Chalk, Star, Dry Brush, 
Sponge, Rolled Rag, Plastic Wrap.
TIP: To see the names of the Brushes in your Brush Palette, click on the arrow 
button in the palette and select ‘Large List’

B. ‘Painted Image’ Clipping Group method
This makes it look like your image is painted on (simulates the ‘Liquid Light’ emulsion 
darkroom technique).
1. Make sure your background layer is unlocked (double-click on the layer to change 

the status & rename it as Layer 0).
2. Create a new layer, and with a huge artistic brush (any of those listed in A.2. 

above), paint all around the center of the canvas, leaving a bit of empty space 
around the edges. Ink colour doesn’t matter. 

3. Drag this layer underneath Layer 0 (should be at the very bottom).
4. While holding down the ALT key, click on the dividing line between this layer and 

Layer 0. Your cursor should change to look like two interlocked circles. When you 
release the mouse, a little downward arrow should show that Layer 0 is grouped 
with the paint layer.

5. Repeat step 4 to the dividing lines with every other layer to group them all and 
apply the clipping mask.

6. Now create a layer underneath everything & fill it with black, white or cream to 
complete the effect.

C. Layer Mask method (Painted Image or Painted Edges) - use only as final step
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1. Once you have finished editing the image, flatten the layers or ‘stamp’ a new layer 
that is a composite of all your existing layers. To ‘stamp’: select your top layer, hold 
down the ALT key and choose Merge Visible from the layer menu.
TIP: ‘Stamping’ keeps all the other layers intact in case you want to go back & re-
edit anything.

2. Add a blank Layer Mask to this layer (click the Layer Mask icon at the bottom of 
the layers palette).

3. Paint into the mask edges with black (for the Painted Edges effect) or invert it and 
paint the centre with white (for the Painted Image effect).

4. Create a base layer underneath this filled with black, white or cream to complete 
the effect.

That’s it for this workshop. If you like what you read, found something useful (or incorrect!), or 
want to share your own ideas, please don’t hesitate to send your feedback to:

mail@mikocoffey.com

Thank you!
Miko
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